No announcement yet.

Audio dropouts when 8 or more clips are playing simultaneously

  • Filter
  • Time
  • Show
Clear All
new posts

  • Audio dropouts when 8 or more clips are playing simultaneously

    The title is pretty self explanatory, but I’ll expound a bit.

    I’ve been putting together a live set with the intention of using Bitbox as a clip launcher. It works beautifully until I launch the 8th or 9th cells (while the others are still playing), then it reacts similarly to a cpu spike with the audio dropping out completely or glitching. Sometimes everything else will drop out except for the most recently launched cell. When I start deactivating cells the audio eventually comes back. Again, this never happens when I only have a handful of cells active at once, but it’s really throwing a wrench into my live plans.

    Anyone else experienced this issue?

    Thanks in advance!

  • #2
    Yes, I've encountered this problem before, but I am usually getting up to the last few cells before it starts to happen.

    Bitbox's audio engine is really only designed for 4 voice polyphony, but if all of the samples are one-shots, it will handle it fine.

    When the clips are quite long, it will start to reach its voice limit much sooner. 8 or 9 voices sounds about right.


    • #3
      The number of voices you can play at once depends on a number of things:
      1) Whether the samples are stereo or mono. You can play more mono samples at once.
      2) The polyphony settings of each cell. You could be asking the box to play 64 voices at the worst case (16 cells * 4 voices each). Use monophonic mode whenever you can.
      3) The sample rate of the files themselves. If you are playing material at unity pitch, then using 48KHz files will buy you some overhead. The engine is running at 48KHz.
      4) The length of the files. Short ones will reside in the cache memory and you can get more of them at once. Long ones have to be streamed from disk. You can reliably play up to 4 really long files. Beyond that, they better be short enough to fit in the 64MB cache.

      Let us know if this does not help.