Announcement

Collapse
No announcement yet.

MIDI Input not working

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • MIDI Input not working

    I have just bought a Bitbox from Sweetwater. I am trying to trigger samples with MIDI with no success. I have tried using Beatstep Pro, QuNexus and QuNeo and the Bitbox does not respond to any of them. I verified the QuNeo grid pads are sending out drum nots on channel 10 notes 48 and 49 with a custom configuration and I am using the adaptors that came with my Beatstep Pro. It seems like there may be something wrong with my Bitbox.

  • #2
    John,

    Sorry to hear about the difficulty. How exactly are you connecting these modules? Have you tried a TRS cable directly from the MIDI output of the BeatStep Pro to the MIDI input on bitbox?

    Here is another tip: try MIDI test mode on bitbox by holding the Home button while powering up. Press Info a few times until you get to the MIDI input screen. This will show the raw bytes coming into the device. CAUTION: one of the tests will play loud sine waves through all four outputs. Be sure to disconnect or turn down your audio to avoid getting blown out of your chair.

    Let us know if this does not help.

    Comment


    • #3
      I did try a TRS cable direct from the BeatStep Pro and still nothing. I just tried the MIDI diagnostic mode as suggested above and it shows all 00s. I know the midi expander in the image is sending because I can connect to a Volca Beats and trigger drums.

      Comment


      • #4
        Here is a better picture with all 3 things of concern in frame.

        Comment


        • #5
          There is a problem with the BeatStep Pro adapter you are using. The black/white one is not for MIDI. Try the one with the gray end instead.

          Please also try diagnostic mode with the BeatStep Pro connected to the bitbox via a TRS cable, if you haven't already done so.

          Comment


          • #6
            Here is a shot with the BeatStep Pro. It has the same problem with a TRS cable straight to the BitBox.

            Comment


            • #7
              In that case I must conclude the hardware is faulty. Let's continue this conversation via email and I will arrange for a replacement. Sorry for the hassle.

              Comment


              • #8
                I got the replacement today and got it into my rack! It works great! Hooked up the QuNeo grid and I am able to trigger samples with it perfectly! Thanks!

                Comment


                • #9
                  I’m glad to hear you got a working unit. Thanks so much for your patience. Enjoy the module!

                  Comment


                  • #10
                    I’m having the same problem with my Box. Using TRS from BeatStep to BBox. Nothing on midi channel 10 (or any or any other for that matter. I tried them all just to be sure.) i’ve checked my pads. I’ve tested it with the SynthBox and Bitbox firmware with the same results. Click image for larger version

Name:	4B5336EC-662F-4CE2-A19E-0DA8DBB9F2F2.jpeg
Views:	246
Size:	100.2 KB
ID:	612

                    Comment


                    • #11
                      Khrisblite,

                      Please note that the instructions are different for the BeatStep (not Pro) than the BeatStep Pro. You will need an adapter of some kind. You can use the BeatStep adapter to convert the two wire connection to 5-pin MIDI and then a 1010 compatible adapter to convert to the three wire connection. Alternatively, you can convert from the two wire connector on the BeatStep directly to the Bitbox with a cable you make yourself.

                      More detail on the bitbox side of things can be found here.

                      Let us know if you need anything.

                      Comment


                      • #12
                        Thanks for the reply
                        Having so much trouble with this thing.
                        So I decided to move on from midi for now (until I can get an adapter that will work)
                        But now I’m having terrible loading issues. Essentially with the SynthBox firmware. On startup, no waveforms are displayed and it will say “loading” until I manually select each Wavetable and load a wave. I can’t switch presets with the - / +. The only way I can switch Wavetables is to select them one at a time with the load button. I can’t scroll/preview through waves.
                        How should I be saving the firmware to the SD card? What should it look like on SD card? Are leaving things in their folders ok?
                        I bought SynthBox new from Perfect Circuit Audio. When I got it it had FXBox firmware on it. I didn’t think anything of it at the time because it seemed easy enough to switch firmware.

                        Comment


                        • #13
                          Hi Aaron,

                          i got a Bitbox and want to connect it to Midi from my DAW (or Synthstrom Deluge) which have both the standard Midi cables.
                          I also ordered the TRS-Midi cable from you (still waiting for), i hope i did the right thing and this will work?

                          I will also order the Toolbox in the next weeks, and hope the same for that ?

                          Comment


                          • #14
                            Originally posted by khrisblite View Post
                            But now I’m having terrible loading issues. Essentially with the SynthBox firmware.
                            Khris,

                            It sounds like your Synthbox disk image is not constructed properly. Please make sure that you start with the synthbox 1.0 firmware (which includes the presets and wavetables) and then overlay the synthbox 1.0.2 firmware, which only includes the code. The result should look like this screenshot on the microSD card.

                            Please let me know if that does not address the issue.

                            Comment


                            • #15
                              My Bitbox is also not responding, FXbox too, Synth not tested.

                              I am using a Beatstep pro cable with grey connector.
                              In the test screen some bits are rushing through, if i use all channels a lot of bits.

                              But no reaction ?

                              I think i will give it back.
                              Last edited by Trooper; 11-27-2017, 10:42 AM.

                              Comment

                              Working...
                              X