Announcement

Collapse
No announcement yet.

looping a sine wave

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • looping a sine wave

    I am trying to loop a sine wave that was created with sox (http://sox.sourceforge.net/). The file is 24-bit/48kHz at 261.63 Hz (middle C) normalized to -12dB (to ensure that clipping will not be an issue). I am using forward looping together with the gate launch mode. I have tried different lengths but the result always ends up distorted. I am using the 1.1.0 firmware.

  • #2
    For best results, I recommend that you produce the WAV file with an exact number of full cycles. Then, you can just let the loop points to the start and end a have a good loop. I am going to guess that the problem you are having is that you don't have the perfect loop points.

    Comment


    • nibr01
      nibr01 commented
      Editing a comment
      I tried with up to 6 full cycles. Do you have a file that I can test with? I am starting to get worried that there may be some hardware issue with my unit.

  • #3
    Originally posted by nibr01 View Post
    I am trying to loop a sine wave that was created with sox (http://sox.sourceforge.net/). The file is 24-bit/48kHz at 261.63 Hz (middle C) normalized to -12dB (to ensure that clipping will not be an issue). I am using forward looping together with the gate launch mode. I have tried different lengths but the result always ends up distorted. I am using the 1.1.0 firmware.
    try using the "hardcore and softcore" apps:

    https://www.floats.se/software

    The default settings for digitakt work pretty well for the blackbox.... once you import them as samples set the launch mode to gate and then turn on loop mode.

    Comment


    • nibr01
      nibr01 commented
      Editing a comment
      Thanks. I tried them but the result still has distortion-like artifacts.

  • #4
    nibr01
    Have you tried adjusting the filter on that particular track? I was having a similar issue with an imported sample. Enabling the hi, or lo- pass might give you better results. It worked for me.
    Another thing to check would be the audio signal coming from Blackbox. The signal tends to be a little "hot". If you're not using a mixer to attenuate the signal, I would highly suggest you do.
    Last edited by jdg179; 08-31-2019, 09:39 PM.

    Comment


    • nibr01
      nibr01 commented
      Editing a comment
      I am using a mixer but I have not tried changing the filter settings. I will try it when I get the chance, Thanks for the tip!

  • #5
    On this note I’m wondering if anyone has made a nice pack of blackbox standard waveforms they would be willing to share?

    Comment


    • #6
      Load up the AKWF collection of single cycle waveforms. They work great, except that I can only get about 7-8 oscillators going before it chokes up the blackbox. You do have to manually tune them down a whole step since they are tuned to D2 as default, but now that bb has pad copy/paste, it's not such a chore to get an oscillator bank going. Cheers

      Comment


      • #7
        Thanks bleebox I’ll find these and try out. 7-8 oscillators isn’t too shabby considering the size of this this instrument!

        Comment

        Working...
        X