Announcement

Collapse
No announcement yet.

Disable midi on a pad

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Disable midi on a pad

    I am routing midi through blackbox so I can't disable midi everywhere, I am curious if there is a simple way to prevent specific pads from being triggered from an external controller. Here is the issue: It seems like even though I have keys and pads assigned a specific midi channels, if a pad containing a sample is active/selected (say on the mix screen even) , it still gets triggered by the external midi key controller even when they controller is sending on a channel that is not the key or pad channel. Is there a way to set the pad to ignore being triggered by an external midi controller even if the pad is selected? What am I missing? It seems like an active pad has midi set to omni by default, the pad is being triggered only by the internal sequence otherwise

  • #2
    You might have a look at the Pad Note parameter. You can set a custom MIDI note for a pad to respond to. You can set it to a note# far out of the range you are sending through the blackbox.


    There are a few things to consider when using MIDI with the blackbox.

    Here are the options:

    Set TOOLS > MIDI Pads to select a global channel for all Pads. In this mode, the blackbox will respond to MIDI Note #s 36-51 (lower left is 36. upper right is 51). When the blackbox receives one of these note #s, it is the same as touching the main pad screen. So if you have a one-shot, this will trigger it. If you have a synced Clip, you can send that note # to both start and stop. Just like touching the main pad screen. If you want the Pads to respond to different MIDI note #s, you can adjust the Pad Note parameter on the MIDI page. This method is best for one-shots or drums or samples you want to play as-is with no change in pitch.

    Set TOOLS > MIDI Keys to select the incoming MIDI channel that will control the currently selected pad as a chromatic/melodic instrument. You can use the knobs to change the selected pad, thereby changing the current instrument. This mode is great for a keyboardist, for example, to load backing tracks and also have a few different sounds/patches for soloing, etc.

    On the selected Pad, press the INFO button 2x. Touch the MIDI tab in the lower right corner. If you set the MIDI In channel here, instead of in TOOLS, you create a direct pipeline from your incoming MIDI to that Pad, on the selected channel. This approach will also play the loaded wav chromatically/melodically so this is best for triggering multiple Pads on their own channels.

    You can set the MIDI Out channel independently for Pads vs Sequences. The blackbox does not have a MIDI Thru. The result in setting a Pad to MIDI In: 1 MIDI Out" 2 is - any MIDI data received on channel 1 will be redirected to channel 2.

    Comment


    • #3
      thank you Steve, I will give your out of range pad note parameter a try. My problem is that I have rather delicately arranged slices on certain pads using the sequencer along with the slicer sliceseq function to step through them, i just seem to inadvertently trigger them when messing around say on the mixer page and then simultaneously striking my midi controller (being routed through blackbox with no intent to trigger it ) with said pad now active thus throwing off the whole arrangement unintentionally. I should probably add some more "wish list posts" to the wish list board (for instance make pads selected in mixer page have no bearing on the pads page) , though it appears I'm using the device in such a abberant manner my solicitations rarely get any upvotes.

      Comment


      • Steve
        Steve commented
        Editing a comment
        Let me know if you need help or if that solution does not work.
    Working...
    X