Announcement

Collapse
No announcement yet.

Black Box and Novation Launch Control XL how to get'em working together

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Black Box and Novation Launch Control XL how to get'em working together

    hey fellows,

    please help me not getting desperate.

    I'm trying to get Launch Control working with BB. I know it should work but Im not able to get this done.

    this is what Im done so far:
    • creating a new PSET File
    • connecting Launch Control via USB (the only way to connect)
      • connected as normal power mode
      • connected as low power mode
    • the only result Im getting is a fancy running flash light, no communication.
    Something I may do wrong, but I have no clue what.

    Thanks
    Last edited by TheSchizoid; 02-12-2020, 08:07 AM. Reason: adding tags

  • #2
    The Launch Control is looking for midi notes erm, from C1 to E2 if I recall for pad triggers, probably F2 and up for sequence triggers. I literally just bought the Launch Control XL last week after watching Ricky Tinez with his on the blackbox (also the reason I bought the blackbox :P)

    You can map the sliders and rotary encoders to Midi CC control as Ricky shows: https://www.youtube.com/watch?v=T35StPF9y6Q

    You can find info in the downloadable manual for the blackbox, you can plug the XL into your windows/mac PC/laptop and use the Novation Launch Control program to look what pads are mapped to what notes for the pads and match them up.

    I hope that helps, I'm a beginner myself with the BB and XL.


    Comment


    • #3
      for me the same reason I bought the blackbox

      I got my launch control just yesterday.

      yeah, it looks so easy in Ricky's video. But when I do the same I don't get the knobs and sliders to connect via midi learn. When I connected LC to BB, it turns immediately in Las Vegas Mode, the mode where u see running flashing lights. For some reason I don't get them to speak each other.

      Do you got the MK1 or the MK2 version? Have you connect LC in Low Power or Normal Power Mode? And what MIDI channel do you use?

      Im also a beginner

      Thanks

      Comment


      • #4
        Regarding vegas mode on the Launch Control, try using blackbox with the supplied power cable and power supply. Sometimes that is the issue. Try disconnecting and reconnecting the controller.

        Regarding the mapping, as of version 1.4, you can map the MIDI trigger note for each pad. So, you won't need to reconfigure the LaunchPad from its defaults. We will be posting a manual for blackbox 1.4 later today.

        Comment


        • #5
          Originally posted by Aaron View Post
          Regarding vegas mode on the Launch Control, try using blackbox with the supplied power cable and power supply. Sometimes that is the issue. Try disconnecting and reconnecting the controller.

          Regarding the mapping, as of version 1.4, you can map the MIDI trigger note for each pad. So, you won't need to reconfigure the LaunchPad from its defaults. We will be posting a manual for blackbox 1.4 later today.
          Aaron I can confirm I'm using the supplied power cable and, at the moment, an USB hub powering with 5V/4A power supply. Technically it should get enough juice. LC has two different power mode, normal and low power, I tried both but no positive effect.

          Comment


          • #6
            Have you updated the firmware in the blackbox and the LaunchPad?

            Comment


            • #7
              Yes. both are updated to the latest firmware.

              Comment


              • #8
                I'm sorry to say I don't have a LaunchControl to try this out. Has anyone else had success here?

                Comment


                • #9
                  Also, please try the power supply we supplied. This sounds like a power problem and it would be prudent to rule out your hub, regardless of the specs. Thank you.

                  Comment


                  • #10
                    Sorry for the slow reply.

                    I have updated firmware to 1.4.1 I think it's at and the Launch Control is the MkII, I have no idea if it's low power mode or not. Powering the BB I have an Anker powerbank (appears to run it for about 3 days at 6hrs a day, *roughly*). It does a running lights thing at power on but that stops after a second.

                    Comment


                    • Steve
                      Steve commented
                      Editing a comment
                      Powering the BB with a MIDI controller connected via USB might be drawing too much from your power bank. Try using the BB supplied cable and adapter to be sure that power is not the issue.

                    • subbass
                      subbass commented
                      Editing a comment
                      @Steve I'm not OP, I meant that it does the disco light thing and then works fine as OP had mentioned the lights so I was just saying that they do come on for a second.

                      I have no issues with my BB/Launch Control thankfully, other than initially working out how to set the pads which I (kinda) described assigning notes in my first reply.

                      Cheers

                    • Steve
                      Steve commented
                      Editing a comment
                      Thanks. I meant to post this as a comment rather than a response to you, specifically!

                  • #11
                    Sorry for my late reply.

                    Just today, the replacement blackbox arrived. No issue anymore with LC. No Las Vegas Mode, cc learning identification works. works even with my 5V/4A USB Hub.

                    Thanks for your help

                    Comment


                    • #12
                      I also have an issue with the Launch Control XL Mk 2. When I connect it, it goes to the same demo ("vegas") mode, but also it makes BB make a short "zzz", crash and restart every few seconds. I'm on 1.5.1 firmware on the BB, Launch Control is at the latest version.

                      Later edit: also, the screen becomes unresponsive to touch. The physical buttons work. If I restart BB with the Lauch Control still connected, the touch screen works again, but the controller is still in demo mode.
                      Last edited by adam.wise; 05-24-2020, 02:55 AM. Reason: added more details

                      Comment


                      • Fotopaul
                        Fotopaul commented
                        Editing a comment
                        What kind of power are you using? Do you have any way to test it by connecting to an external midi router and then into the BB?

                    • #13
                      Guys this is why its not working...

                      The Novation XL MK2 is different to the previous version, his main update was about the ability to reproduce RGB pad color...
                      This (not lovely) new feature make him more power hungry.
                      Sooo version MK1 can work standalone plugged with low power materials like ipad etc... MK2 not i guess

                      Try to connect the novation mk2 with a powered USB HUB should work or stay with the MK1

                      Ps: a "Rainbow looping "state or "vegas mode" with a midi contrĂ´ler is always the sign that he has not enough power to start, its like a sleeping mode.

                      Comment


                      • #14
                        It's worth noting that anyone using MacOS Catalina does not have access to the Launchcontrol XL editor. Novation hasn't made a 64 bit version yet. This is what has kept me from picking one up to bring some non-mouse control to Bitwig. I'm sure Novation will make a new version of the editor eventually, they are usually great about this sort of thing.

                        Comment


                        • #15
                          Originally posted by Fotopaul
                          What kind of power are you using? Do you have any way to test it by connecting to an external midi router and then into the BB?
                          Mk2 does not have MIDI sockets, it's USB only. But I'll test other ways to power it.

                          Originally posted by Blond12 View Post
                          Guys this is why its not working...

                          The Novation XL MK2 is different to the previous version, his main update was about the ability to reproduce RGB pad color...
                          This (not lovely) new feature make him more power hungry.
                          Sooo version MK1 can work standalone plugged with low power materials like ipad etc... MK2 not i guess

                          Try to connect the novation mk2 with a powered USB HUB should work or stay with the MK1

                          Ps: a "Rainbow looping "state or "vegas mode" with a midi contrĂ´ler is always the sign that he has not enough power to start, its like a sleeping mode.
                          I don' have a Mk1 to test. But thanks for the suggestion, I'll try and see with a power hub or with BB directly to the socket. Right now I'm powering it through a PC USB 3 port, and realised it might not give enough juice.

                          Comment

                          Working...
                          X