No announcement yet.

Please help - Can't save preset v1.6.5

  • Filter
  • Time
  • Show
Clear All
new posts

  • Please help - Can't save preset v1.6.5

    First off, Blackbox is awesome. Been tinkering for a couple weeks now and it's exactly the kind of instrument I've been searching for. Great work 1010.

    But I have a problem on 1.6.5 and I could really use some help: I cannot save a preset. The Save button is greyed out as are several of the usual options in the File menu (like Save As and Pack). See attached pics.

    I saved backups of all my samples to be safe. But I have a cool session going that I spent a bunch of time developing and I really don't want to lose my work, so I'm leaving it powered on until I can save.

    Can somebody help? I'm not able to find the 1.6.5 version of the manual, but 1.5 doesn't have any info on this issue and I didn't find a similar problem on this forum. I tried swapping back to the original SD card to see if I could save to that but the problem is the same. I was able to save presets normally before v1.6.5 (I updated this morning from 1.5.j I believe).

    Thanks to anyone who is able to save my Friday...

  • #2
    Save is not available because there are no new changes to be saved. You will only be able to select the operations that are currently available.

    If you are saying that you made changes that do not stick...that is another issue and I'd be happy to help.

    FYI - there is a thread in the blackbox firmware update section that lists the updates, changes, fixes for each version.


    • #3
      Thanks Steve. Yes that's the problem; I cannot save any new changes. I'm pretty familiar with the workflow from the previous versions and 1.6.5 is not the same. Normally I can just hit the PSET button, then hit Save (or choose Save As) on the screen and I'm all set, but these options are greyed out, even after making new changes to the preset. When I do hit PSET, it takes me to the root of my SD card and highlights the first folder. I think 1.5.j took me directly to the current preset folder when I hit PSET but I'm not sure I'm remembering that correctly.

      Hopefully this is just user error. I will jump into the firmware section of the forum and see if there's any new info there. Thanks for the quick response.


      • #4
        I pulled the SD card and looked at the preset folder on my computer. There is a preset.xml file there but I can't tell when it was created/modified as the file date is 12/31/79 at 11pm (all files have this date). There is no preset.als file in the folder however, which all of my other preset folders have. Is it possible the preset.xml was saved automagically?


        • #5
          Here's the preset.xml. My guess is this is the template file as it shows a tempo of 120, etc. and mine preset has different settings. But maybe it will help...
          Attached Files


          • #6
            Can you verify that you are unable to save a change? Can you send me a video of that? Or provide some repro steps for me to follow?

   the card you were using blank? There have been issues tied to not working inside of a saved preset that might come into play here. If the card was blank, the blackbox will create a new preset to avoid the previously mentioned issue.

            Looking at your preset - you are correct. The tempo is set to 120. Any details you can provide is always appreciated.

            It also takes a few seconds for the device to check if there are unsaved changes.


            • #7
              Just shot a video, will share as soon as it's ready.

              I'm not using a blank SD card. I'm using a new, fully formatted SanDisk via the SD card thread on the forum. I've been using it without issue for about a week. I also tried putting in the original SD card (the one that came with Blackbox) but the problem is the same.

              I tried waiting for several minutes for the PSET screen to update to a "save ready" state but the Save options remain greyed out.


              • #8
                To be clear, I've been using the new SD card for about a week with the Blackbox. I have maybe 10 presets created on that card that have worked fine, along with a library of my samples.


                • #9
                  I posted a link to the video in chat. let me know if you need it another way.

                  I think I misspoke in the video. PSET seems to take me to the Presets folder on the card, not the root of the SD card.


                  • #10
                    This appears to be an anomaly. I bounced all of my tracks into my DAW and rebooted Blackbox. The preset was indeed unsaved but the raw samples I recorded were saved.

                    Blackbox seems to be functioning normally now upon reboot. I tried a few things but I cannot reproduce the problem. It might be worth mentioning that Blackbox now takes me to the currently loaded preset folder when I hit PSET. When it was malfunctioning it was taking me into the root of the folder that contains all user presets on the card.

                    So for those who want to be cautious: You might want to check the PSET screen as soon as you create a new preset to make sure the save options are there.


                    • #11
                      All recordings are automatically saved to the preset folder. This is handled by the system. Does this explain what you experienced?


                      • #12
                        Sorry for the confusion. I only added the detail about the samples being saved to illustrate what was working vs what was malfunctioning.

                        The problem I had was being unable to save a preset (i.e. sequences, sample settings, etc.). I posted a couple of photos in the first post that show what the PSET menu looked like and sent a video link via chat on Friday. Here are all the steps I took when the problem occurred (in a nutshell, I didn't do anything differently than what I did with firmware v1.5.j, following what I learned from the v1.5 user manual, page 13)
                        1. Created a new preset using the PSET button/menu (a note on the SD card: I'm using a fully formatted SD card following the instructions on the SD thread on this forum. I had been using that card for about a week without issue, having created about 10 presets on it. Since rebooting Blackbox everything–including the same SD card–is working normally again)
                        2. Recorded a bunch of samples, made a few sequences, adjusted a bunch of sample settings, etc. as usual
                        3. Went to save my preset by pressing the PSET button. On that page, the SAVE button was greyed out. In the FILE menu, SAVE AS, PACK, and CLEAN were greyed out. I could not activate those options. This was the case even after making changes to the preset (i.e. these options weren't greyed out due to there being no new changes to save; I was unable to save the preset to begin with, even after making changes). I also waited for the menu to update as you suggested. The SAVE etc. options never became available even after several minutes of waiting.
                        4. I tried saving to the original SD card instead (the one that originally came with Blackbox) but that did not solve the problem. The PSET page was the same, with those options greyed out.
                        5. I looked at the problematic preset folder from the SD card on my computer. It contained a preset.xml file but it appeared to be the default template, i.e. none of my preset settings were stored in the XML file. The samples I recorded were saved in the preset folder, but these were the raw samples, not the WAV files with the associated parameters that can be saved (slices, etc.) as described on page 32 of the v1.5 user manual. There was also no preset.als file in the preset folder.
                        I have since rebooted Blackbox and have been able to use it normally. I have not been able to replicate the problem.

                        If it would help to share the problematic preset folder let me know. FWIW I have been able to save that specific preset folder normally since rebooting.


                        • #13
                          Glad to hear it is working now. I'd take a look at presets if you want to share them.


                          • #14
                            I'm having a similar issue here. I'm working with a few slicers and clips in a preset (all containing my own samples/loops) and I can "save" the preset, but when I switch to another preset, and then go back to the one I was working on, none of my clips are saved and the entire 4x4 square grid is blank. I have done this 3 times now, all with the same result. Things are getting desperate/infuriating over here. Would love to know if I'm doing something wrong, or if this is just a bug in 1.6.5


                            • Steve
                              Steve commented
                              Editing a comment
                              What are the specs of your microSD, when did you last format, how do you format?

                          • #15

                            Hey Steve, I'm using the stock SD card that comes w/ the Blackbox. I reformatted today, using the SD Card Formatter app from the SD Card Association (Overwrite Format)

                            Here's a video showing my issue