Announcement

Collapse
No announcement yet.

Issues: new project pads always send out trigger to midi ch1

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Issues: new project pads always send out trigger to midi ch1

    I am writing to report 2 issues I found on the blackbox with the latest firmware.

    1) When I mute a channel in the mix section, if I save the project the mute status is not saved; so loading the project again unmute those pads again. This is not ideal to be honest, and I am not sure why is working this way.

    2) If I create a new project from scratch, all my pads will be empty, but they will all send midi signals to channel 1 at different note tone. I found no way to turn this behavior off. Basically if I create a project, then I add 3 samples, each set to play midi on a different channel in the pad options (pad 1 to ch1, pad 2 to ch2 and pad 3 to ch3), and I connect midi out to a synth; this result in midi always being played on channel 1 AND whichever channel I selected in the pad options. Notice that in the Tools section I selected none for both the pads and keys in midi section.

    Attached a midiox output. The first 2 lines are the pad pressed in an existing project, which I modified to send to midi CH3; that trigger just ch3 correctly.
    The following lines show the new project pressing the first 2 pads; which are set to trigger ch1 and ch2. As you can see, the first pad trigger ch1 twice, the second pad trigger ch1 and ch2.

    Click image for larger version

Name:	Capture.PNG
Views:	174
Size:	57.3 KB
ID:	20016

    The first issue is somehow fixable by muting the tracks again, but it is annoying.

    The second issue makes impossible for me to actually use the blackbox with external synths. The only way I found to have just one channel respond to the pads and keys is to use an existing project and modify the existing pads. So this seems to be a bug in the firmware. Thanks

  • #2
    You might check out the Midi Pads setting in the Tools section. If it's set to omni/all you might have to switch to a specific channel. Check out the manual, there is more info on that topic.

    Comment


    • #3
      Originally posted by Zapman View Post
      You might check out the Midi Pads setting in the Tools section. If it's set to omni/all you might have to switch to a specific channel. Check out the manual, there is more info on that topic.
      That was what I thought; but it is not. I created a new project again, and checked both the pad section and the tools section, and both has no midi set; but if I tap on each pad, I hear the synth on channel 1 triggered, and each pad increase the note pitch; so something has been set by default there, but the UI show nothing.

      I modified an existing project, and checked the XML files, they are identical; but one project is honoring the settings, by playing only the midi channel you specify in the pad; while any new project does not. You can easily reproduce by creating a new project and then use midiox or any other midi tool, to check what is triggered. If you change the pad midi output setting, it will trigger both channel 1 and the channel you set in the pad; while in tools, both keys and pads are set to none for midi.

      Comment


      • #4
        Having this exact issue

        Comment


        • #5
          Check that you do not have MIDI Out set on a sequence as this will create this behavior. Since all pads point to the #1 sequence by default if you have a MIDI CH set in the sequence settings your MIDI will play on the channel set in pad settings and the channel set in the sequence. Can you verify that this is how your box behaves? In other words, if you turn off all MIDI at the sequence level, does this continue to happen? You mentioned making a new preset. New presets should all default to sequence MIDI Out: None.

          If you are ultimately sending MIDI from a sequence - you do not need to enable MIDI at the pad level. Only in the sequence. Please let me know if this does not resolve your issue.

          Comment

          Working...
          X