No announcement yet.

Multi sample mode not working in ver 2.0

  • Filter
  • Time
  • Show
Clear All
new posts

  • Multi sample mode not working in ver 2.0

    I’ve made many multisample banks since the automation feature was added a few updates ago. Love it! It’s my custom Rompler, but now with version 2.0 it doesn’t seem to play the samples after they are recorded. This issue only applied to new samples. Ive loaded previous multis I made with version 1.7 and playback on keys works fine. New samples don’t seem to work. The samples make to the file directory and I can play the individual notes files while scrolling in the file menu but again cannot be played in the keys. Is this a known bug? I hope you fix this feature.

  • #2
    I know I've not had an issue recording and playing back multi-samples in 2.0


    • #3
      Same issue here as op. I tried to automate sampling for some instruments in Ableton and it seemed to operate as if it was working but wouldn’t add the correct sample (would just add another from the same preset folder) when finished. It would often disregard what I just recorded and load an old sample.

      Also when I sample a kick that's mapped to C1 in the Kontakt instrument, I have to actually tell the Blackbox to send C2 over midi. Then it auto records the velocity layers (3) and when I press the pad it plays back the kick 2-3 octaves higher. If i just load one of the velocity layers in and press the pad it will play back at the right pitch. Even if i tell Blackbox what the root and pad note are it still plays back octaves higher. I randomly get false starts as well where Blackbox will say it's recording note 1 of 3, but won't actually record anything (file is empty) and will stay stuck on note 1.

      This all worked great prior to this update.
      Last edited by modul8r1; 11-09-2021, 11:26 PM.


      • Steve
        Steve commented
        Editing a comment
        There may be an octave shift depending on which 'C' a particular synth or preset uses as its Middle C reference. This might explain your second issue.

        I need more info on your first paragraph. Please explain further.

    • #4

      If I sampled a kick (with velocity layers) from the software instrument in Ableton mapped at C1, when recording stops I get the waveform display and a sample playing back 2-3 octaves higher for some reason. Then when I move to the next pad to sample the snare with velocity layers, mapped in Ableton at D2, when it finishes I get a waveform display with the same kick I sampled. From there it just keeps loading the old kick instead of the new sound I/m sampling.

      Regarding my second issue, I understand there may be a shift based on where a synth or software plug has mapped middle C. But every single time I sample a drum from a plugin it plays the drum 2-3 octave higher when I press the pad. Why is that? Even if I tell it in config what the root and pad note are it still plays back way too high when I press the pad.

      So I sample a kick at C1 (i have to tell blackbox to send C2 to trigger C1) it records and when it loads afterward the multisample of that kick plays way to high. If I just clear the multisample and load only one of its layers, it plays at the expected pitch when i press the pad. It's as if some global pointer isn't being written into the .wav tag for all multisamples, but it's written into individual files?
      Last edited by modul8r1; 11-12-2021, 04:21 PM.


      • #5
        Thank you for that level of detail. I can't explain that one... But I would like to see it. Can you post a video of your Mx process so I can see what you are doing and hearing before, during, and after the Mx recording process?


        • #6
          I haven't been able to make a video but I may be able to try soon as I'd really like this feature to work.

          Just wanted to update this, I recently needed to multisample a bunch and ran into the pitch issue again. I downgraded to the latest 1.7 firmware first.

          I opened a Kontakt drum instrument on my computer and sent midi from blackbox to my computer with a MIO interface. Everything here is fine. Sent Kontakt audio from my Apollo 8p into the Blackbox. All fine.

          EDIT: I created a new preset before the following steps.

          Next I started the multisample process (info button, select MX, set the note i want to sample, 6 velocity layers). I even went into Misc. and set the root note. I hit record and when it finished it gives me the waveform screen.

          When I tap the pad to trigger, the sample always plays around 2 octaves higher.

          Before and during sampling i hear everything as it should be. The minute it loads all the samples after recording the pitch is too high.

          If I clear the sample, go into the folder for the sound I sampled and load just an individual velocity layer (in this example Snare 2-041-080.wav) the sample instantly plays at the correct pitch. If I load the 5 other layers individually they play correctly as well.

          If I then try to load all 6 as a multisample (File > load all) instantly we're back to the high pitch.

          I checked the root note for each of the 6 velocity layers individually and they were correct. I then manually saved each .wav file again with the correct root note (as you would if you multisampled manually) and still no luck.

          A little shocked no one else is reporting this! Especially as it goes back to 1.7 apparently. Please help!


          • #7
            I also hope multisamples get fixed


            • #8
              Originally posted by modul8r1 View Post
              A little shocked no one else is reporting this! Especially as it goes back to 1.7 apparently. Please help!
              thanks for the steps. Others are reporting it and have sent videos! I still have not been able to reproduce it on my end though I have seen it in videos. Can you send the files created by your box? Also, the preset? I'll continue to look at this until we get a fix.


              • #9
                Here's one:


                The two kicks are supposed to play at B1 for Kick 1 and C2 for Kick 2.

                Snare 2 is meant to play at D2.

                Tom 1 is meant to play at F2.

                The rest I've pitched down with the pitch knob to match the original Kontakt instrument.

                I'd missed reports on this specific issue, I'll get to searching!

                Next I'm going to try using Ableton (can I?) to set the proper root notes and see if Blackbox will load them correctly. And I've already started preparing instruments in Logic's Auto Sampler to create Multis but haven't loaded them.

                Regarding Sample Robot, I've read some people here are using the Korg version. As I understand it, that version doesn't support 24bit export? Anyone care to shed some light?

                As I mentioned I'm digging in Auto Sampler in Logic Pro. I sampled the same drum kit, batch converted the samples into .wav with TwistedWave (anyone know if there some hidden setting to Auto Sample with wav files? )and loaded the multisampled hits into separate pads as before. Everything played back exactly as expected with the exception of *maybe* the kicks which sound a tiny bit boomier and lower. This could be down to the mic blend or round robin. Will investigate further tomorrow. Things are looking up!
                Last edited by modul8r1; 12-17-2021, 12:21 AM.


                • #10
                  That appears to be true about SR Korg. I'm thinking it did not have this limitation when I bought it. That was 2 years ago. If your MS sets are small, it is easy to load one wav at a time and set/save IN the blackbox. It's maybe not the favorite long-term solution but it is something until you land on a solution that works for you. I'm now considering paying for the SR update. That app does all the things you need and is very quick and easy to use.

                  The last time I checked Apple's AutoSampler plugin, it did a great job of both capturing and properly naming samples. I don't think it saved the RootNote to the wavtag (like our samplers need) but they do work well in their new MultiSample Instrument. You can also create sets in the Sampler Instrument and Logic will export and rewrite the filenames with all the important info. However, our samplers still require the RootNote to be saved to the WAV file in order to work properly.

                  I downloaded your content and will look at it for clues. Thanks for sharing this.


                  • #11
                    Is this firmware update a fix ?

                    • With certain WAV files, the box would have trouble writing the root note and other meta data. (The problem was with mono 24-bit files).


                    • #12
                      Yes, we believe so. Please try and let me know.


                      • bibenu
                        bibenu commented
                        Editing a comment
                        I'm just a lurker here (not owner), can't try it. This bug was putting me off buying it, so I'm interested to hear back from someone else.

                      • Steve
                        Steve commented
                        Editing a comment
                        We continue to work on the blackbox. There is no reason to believe we won't fix things like this as it affects major functionality. This should be fixed in the most current firmware.

                      • bibenu
                        bibenu commented
                        Editing a comment
                        Thanks for that comment Steve.

                    • #13
                      Multisampling with v2.0.5 works fine for me, just sampled a few of my favorite QY100 patches. This is one of my primary uses of Blackbox. I didn't have any issues multisampling with v2.0 though.


                      • Aaron
                        Aaron commented
                        Editing a comment
                        Glad to hear it.

                    • #14
                      Hi everyone,
                      I have the same problem (hi pitched playback) with multisample and velocity layers now in 2.1.3. Is there any fix or workaround?


                      • #15
                        There is a limit for pitch bending a mutisample. If you have exceeded that limit you may consider adding more samples to the set.