Announcement

Collapse
No announcement yet.

Unable to loop samples without clicks

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Unable to loop samples without clicks

    Hi,

    I loaded some loops I made in my DAW but I wasn't able to loop them in the BB. I tried and tried again for hours with different loops and settings, both in my DAW and in the BB, but there's always a tiny click at the beginning. What am I doing wrong? Or is it some kind of bug?

    Here are 2 loops, one in 44.1khz and the other one in 48khz https://we.tl/t-yqt5DCgpi5
    bpm 120
    3 bars

    Thank you.

  • #2
    There isn't currently any zero crossing detection for loops, but a workaround is to set the Attack a bit above zero to avoid clicking.

    Comment


    • #3
      Originally posted by Dan View Post
      There isn't currently any zero crossing detection for loops, but a workaround is to set the Attack a bit above zero to avoid clicking.
      I know, that is why I make my own loops in my DAW beforehand, so they are already cut perfectly and loop without clicks.
      The MPC Live does not have zero crossing but I never had problems with this as the loop is already "zero crossed".

      I tried any setting I could think of, including different ADSR settings. Same problem.

      Looping is 99% of what i need, somebody please help me

      Comment


      • #4
        I had a look at your samples in a wave editor and both of them are out of phase and the start and ends are not edited at zero crossing points. You'll have to either trim them to a zero crossing point or add a short fade at both ends to avoid getting clicks.

        Comment


        • #5
          Thanks, yes they are wide and out of phase, but that doesn't matter when it comes to looping. In fact, as I said, I had no problems with my mpc and they also loop perfectly in my DAW, without clicks.
          I will make a new loop and upload a version of it looped in my DAW and another one looped with the blackbox.
          Thanks again for taking the time to help me.

          Comment


          • #6
            Ok, so here is a mono sample in 44.1 https://we.tl/t-9vvkDa7xqv
            120bpm
            1 bar
            length 4 seconds
            176400 samples (I checked in both my DAW and in the BB)

            I rendered this sample and loaded it in the blackbox and in my DAW as well. I looped it one time (so it's 8 seconds now)

            In the DAW file, it loops as it should at 4 seconds. No clicks.
            In the Blackbox file however, you can hear a tiny click at 4 seconds.

            If you can loop this sample in your DAW without any click, than the problem is in my DAW but that's very unlikely, as I said I had no problems with my mpc.

            Comment


            • #7
              If the start and end point of a loop are not at the same level, you get a very sharp transition. In terms of audio that results in a pop/click. Your DAW and mpc probably do some processing when looping the sample to remove this sharp transition (very short fade, or snap to nearest zero crossing for example), the Blackbox currently doesn't. This feature has been requested I think.

              Comment


              • #8
                Originally posted by pieter3d View Post
                If the start and end point of a loop are not at the same level, you get a very sharp transition. In terms of audio that results in a pop/click. Your DAW and mpc probably do some processing when looping the sample to remove this sharp transition (very short fade, or snap to nearest zero crossing for example), the Blackbox currently doesn't. This feature has been requested I think.
                From what I know, the mpc doesn't have a feature like that and people were asking for fades/zero crossing option to be able to make loops. That is why I always create loops in my daw, without tails, perfectly cut on grid and on zero crossing points.

                Looping without clicks in this case, should be a normal behaviour for any daw, sampler...

                I hope they are going to solve this problem asap

                And btw, the end and start point of this loop, are exactly at the same level. In fact, the beginning of the loop is the continuation of the end of it, that's why it should loop without any click. I didn't use fades to loop that bar.

                Comment


                • #9
                  I tried the 48K cello. I hear a small click if I turn it way up. I can make it go away if I move the end point earlier by one sample to 287999. Is this what you are seeing?

                  Also, if you want super high powered loop crossfading, try granular mode with speed set to 100%.

                  Comment


                  • #10
                    Hi Aaron, thanks for checking.

                    Something crazy is happening now: if I load that Cello 48K sample it loops perfectly, then I move the end point by one sample to 287999 as you suggested and it works without clicks. Then, I set it back to 288000 and now the click is there. I swear I'm not going crazy I tried it several times, with different cells and with the release set to both default 20% and 0% (just in case that makes any difference).

                    So I tried with the mono 44.1 sample I provided in post #6. This one works if I cut 2 samples at the end.

                    If it's not a bug, I don't know what it is. Again, all these samples loop as they should in my daw, now I'm going to make new ones just to see what happens.

                    Comment


                    • #11
                      I tried with some new loops and it works just fine, I don't know what happened (I also reinstalled the firmware).

                      These 2 loops work as they should in my daw https://we.tl/t-WLC9zWItj3 (both 120bpm)
                      but in the blackbox, the loop called synth won't loop without a click unless I cut 2 samples at the end. The loop called sub works.

                      Comment


                      • #12
                        Just an update: today I noticed one thing. I loaded 4 loops and while playing with them in pads window, the clicks were there (unless I cut a few samples at the end as Aaron suggested). If I make a sequence with those 4 samples and hit play, they loop as they should, without clicks. I'm going to try other things with different loops.

                        Comment

                        Working...
                        X