Announcement

Collapse
No announcement yet.

1.4.0 Blackbox crashing & restarting in a cycle

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • 1.4.0 Blackbox crashing & restarting in a cycle

    Updated to 1.4.0
    Says successful & restarts
    After a couple of seconds it restarts & is stuck in a cycle of restarting

    Re-downloaded update & tried again. Same result.

    Removed settings.tml same result

  • #2
    I just did mine and I am not getting what you describe. Did you get launched into the touchscreen calibration?
    my first guess (and it’s only a half educated guess) when there is any funkiness would be the SD card. Assuming you have a backup of the whole card, have you tried formatting the card and reinstalling?

    Comment


    • #3
      Seems that 1.4.0 can't handle large cards. My 128GB card causes the crash cycle. Just tried an 8GB card & no issue. Reverting back to 1.3.6 & card works fine. My hunch is that it is probably something to do with the load screen sorting.

      Comment


      • underwood
        underwood commented
        Editing a comment
        Works without problems with a SanDisk Extreme 128GB. Copy your SD-Card and try to format it with Rufus instead with Windows format function and copy everything back on the SD card. Rufus can check your SD-Card for errors to.

    • #4
      Worked fine with my 512gb card

      Comment


      • #5
        This is what I'm using: SanDisk Extreme 128 GB microSDXC up to 160 MB/s, Class 10, U3, V30 - MS-DOS (FAT32). What spec is your 512?

        Comment


        • #6
          Can confirm with 128GB card.

          Boots up, empty pads on pad screen, then reboots.

          Unclear why the 128GB cards make it do this but 2 for 2 sounds reproducible to me.

          Using: SanDisk 128GB High Endurance Video MicroSDXC Card 100 MB/s - C10, U3, V30 - FAT32

          I can see why this might have been overlooked but I would suggest 8/16/32/64/128/256/512 be used for regression testing purposes. Not fun I know..

          Comment


          • #7
            No issues with SanDisk Extreme 64GB V30 sdxc1 U3 A2. (golden&red)

            Comment


            • #8
              256g Samsung evo

              Comment


              • #9
                Known successful update SD card sizes are:

                8GB
                512GB
                64GB
                256GB

                Known unsuccessful update SD card sizes:

                128GB (two occurrences)

                ---

                Hopefully this can help the 1010music team.

                I have updated 4 firmware versions successfully and have the exact same behavior as OP with 1.4.0
                Last edited by selfup; 01-15-2020, 06:31 AM.

                Comment


                • shittykids
                  shittykids commented
                  Editing a comment
                  Mine is crashing and restarting with a 32GB card and the new update. Worked great with the same card in 1.3.6

              • #10
                SOLVED - needs to be formatted as exFAT rather than FAT32

                Comment


                • selfup
                  selfup commented
                  Editing a comment
                  Do you know the reasoning behind this? Worked on the version my BB came with and then 1.3.3, 1.3.5, and 1.3.6. Seems odd that it would no longer work.

              • #11
                Oh good to know. It says in the manual that FAT32 is fine. I would ask the team to update said documentation. Thanks!

                Why would I have to change the format of my SD card when I formatted it to a supported format that was supported in 4 prior firmware versions prior to this new update? Just curious.

                I would still say that this is a bug unless there is specific documentation stating otherwise.

                Latest available documentation:

                "Prepare a microSD card with the FAT32, MSDOS Fat, or ExFat format. The card that comes with blackbox is
                formatted properly, but you may need to reformat a card that came from somewhere else."

                EDIT:

                Upon further investigation it looks like FAT32 should be limited to 32GB. Windows uses larger filesystems in FAT32 just fine but I guess this should be taken as truth moving forward? I would say it would be a good idea to include that in the documentation. Thanks!
                Attached Files
                Last edited by selfup; 01-15-2020, 08:18 AM.

                Comment


                • #12
                  Everyone: Thank you for figuring this out while I was sleeping.

                  I didn't think it was possible to format something over 32GB using FAT32. We will update the documentation and see if we can fix the underlying problem.

                  Comment


                  • selfup
                    selfup commented
                    Editing a comment
                    Glad we could find a reproducible symptom! Thanks for looking into it. Hopefully it's not too difficult to fix. Thanks

                • #13
                  Originally posted by Aaron View Post
                  I didn't think it was possible to format something over 32GB using FAT32.
                  It seems on a mac that you can!

                  Comment


                  • #14
                    FAT32 LBA is an extended version of FAT32 that works for drives up to 2TB, and works with Blackbox firmware 1.3.6 (but not 1.4).

                    Would be great if fixing the underlying problem is possible since FAT32 is supported by default on essentially all Linux distributions, whereas exFAT requires installing some extra libraries. Not a huge deal, but I actually reformatted my card from exFAT to FAT32 LBA for this reason, so it'll be a bit annoying to switch back.

                    Thanks to everyone for already figuring this out! Ran into the issue and was super confused, was nice to find the answer on here already.

                    Comment


                    • #15
                      walkie Yea that's what threw me off. I formatted my SD card with Ubuntu and it worked fine for a few versions. Unclear why support was lost.

                      Comment

                      Working...
                      X