Announcement

Collapse
No announcement yet.

USB MIDI sync in/out not functioning

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • USB MIDI sync in/out not functioning

    This is a little tricky because I can't tell 100% where the problem is, but I've tried multiple USB MIDI devices and nothing seems to sync at all. The main goal is to get the Bluebox sync'd with my OP-Z.

    My question is, how can I even attempt to debug or tell what's going on in midi with my Bluebox? It's all supposed to just work, which means there are no UI elements for me to tell whether it's receiving midi clock or sending it, or neither, or whether it even recognizes that a USB MIDI devices is connected.

  • #2
    when the bluebox (or any of our devices) receives an active MIDI Sync or Clock signal, the counter in the upper left corner will reset to 1:1. If you stop the incoming sync, wait 3 seconds before resending the sync signal - the device will automatically reset to 1:1.


    other things to consider - make sure the TRS cable is pushed in all the way. The fit can be snug around those 2 jacks and sometimes the cables go almost all the way in - but not 100%.

    Comment


    • #3
      Originally posted by Steve View Post
      when the bluebox (or any of our devices) receives an active MIDI Sync or Clock signal, the counter in the upper left corner will reset to 1:1. If you stop the incoming sync, wait 3 seconds before resending the sync signal - the device will automatically reset to 1:1.


      other things to consider - make sure the TRS cable is pushed in all the way. The fit can be snug around those 2 jacks and sometimes the cables go almost all the way in - but not 100%.
      I'm using USB for my MIDI rather than TRS. Does all the same still apply?

      Comment


      • Steve
        Steve commented
        Editing a comment
        Yes. This is how all of our devices behave with incoming sync.

      • idylmind
        idylmind commented
        Editing a comment
        I'm also having a USB clocking issue that dates back to day 1 original firmware.  I can't use the USB host to sync an OP-1 to incoming midi of the Bluebox.  I can successfully send clock from an OP-Z (trs midi) through a ZOIA and finally into the Bluebox and everything works/syncs as it should. However, with my OP-1 plugged into the USB host, the second I switch it to EXT sync, the incoming clock to the OP-1 is 2x plus some more and the Bluebox no longer receives sync.  It sure seems like the Bluebox is trying to receive clock from both locations (trs midi and usb).

        2 questions/requests.  
        1: Is there a way/can there be a way to configure exactly how the USB host handles midi?  I would like to tell that port to only send and not receive.

        2: Can the Project settings screen where the (internal) tempo can be set reflect the synced tempo when receiving clock?

      • Steve
        Steve commented
        Editing a comment
        That is exactly what is going on. We recognize the need to be more selective and intentional about sync and will likely address this in the near(ish) future. The bluebox will respond to the incoming clock but does not display that as of now.

    • #4
      Thanks for confirming Steve. Looking forward to that feature update!

      Comment


      • #5
        For the record, is Bluebox's TRS MIDI output Type A or Type B?

        Comment


        • jayneural
          jayneural commented
          Editing a comment
          Hi Steve, is it the same for the input ? Does it auto-detect ? Also will it send thru what it received by default ?

        • Steve
          Steve commented
          Editing a comment
          yes. it should auto-detect and adapt accordingly. It should pass whatever comes in the door!

        • jayneural
          jayneural commented
          Editing a comment
          Thanks’ and that works for both Bluebox MIDI in and out ?

          Was this or will this be also implemented for the Blackbox or does that require some specific hardware ?

      • #6
        I figured out how to make the Bluebox and the OP-Z sync, but I think I found a minor bug in the process. For some reason, the Bluebox only syncs with the OP-Z if the OP-Z is turned on first, and then the Bluebox turned on with the OP-Z plugged into it. If you unplug it or turn the OP-Z off, it won't sync (and transport controls won't work) until the Bluebox is turned off again.

        Comment

        Working...
        X