No announcement yet.

Midi Controller Issue (Launch Control XL)

  • Filter
  • Time
  • Show
Clear All
new posts

  • Midi Controller Issue (Launch Control XL)

    I bought a Novation Launch Control XL for the Bluebox back in March when I first got the device and it worked like a charm for controlling the different parameters of the bluebox. I now haven't used it with the Bluebox in a while, only with Abelton. As I bought my first effects unit, I wanted to reuse the Launch Control XL as a midi Controller and map the volume and send effects to different parameters. But when I plug in the controller into the USB-Port of the Bluebox, it takes forever to boot up or doesn't boot up at all and just flashes lights across the LED buttons. In the rare case that it does boot up, the device isn't mappable with the Bluebox. I have the controller set to user template mode, my bluebox firmware is 1.1.3. I don't know, what to and why it doesn't work anymore, as the controller used to work before and now does not anymore. Has anyone faced a similar issue and maybe even solved it? My fx unit is useless without it because it takes way too long to fiddle around with the touch interface

    EDIT: I downgraded the firmware to 1.0.13 and the issue persists. Also, while downgrading the firmware, the controller has full power and is lit up, but after the upgrade, it falls back to the new problem. It seems like the controller is constantly restarting, maybe it is a power issue. If the controller does start and lite up, I cannot program any midi changes while the Bluebox is in learn-mode, doesn't matter, if I switch the controller to factory mode or to the User-Template mode. I don't know what else to try to find the issue.
    Junior Member
    Last edited by enemoy; 11-01-2021, 08:23 AM. Reason: Spelling correction

  • #2
    Check the Novation manual for Low-power mode. The Device port on our products supports only low-power devices. I have this controller and it works well with my bluebox.


    • #3
      Thanks a bunch, I will try.


      • #4
        Can confirm that Low Power mode works well with the LCXL and Bluebox. Christine very kindly pointed me in this direction via the FB group when I faced similar issues.
        Still to try it out through a mobile battery but i suspect it will work better than my current setup which runs several instruments off a 6A power strip with very little leeway for voltage fluctuations.


        • #5
          I don't quite know how to get it into low power mode, sadly. Is there a control center by Novation?
          On the other hand, I found a workaround being quite useful too. Arturias Keystep 37 provides an adapter which seperates power and data line for the usb input. I used this to get power from an USB outlet and only data, not power, from the bluebox. This works like a charm too, but it takes away more desktop space of course. Still, I wanted to mention it in case anyone wants to know.


          • #6
            This is a great idea to separate the power and data lines for the USB input. Reminds me of an article I had read on exactly this that I think lays out the limited few solutions here. Here's the link:
            "...solve the problem using a “USB split cable”. This type of cable has two connectors that would go the port/hub and it allows the device to draw power from two ports or from a port and an external power source"
            This is one of the cables the article suggests- it is no longer available but alternatives should not be too difficult to find:
            Click image for larger version

Name:	Screenshot 2021-11-11 at 3.52.00 PM.png
Views:	75
Size:	35.6 KB
ID:	29318
            The article also suggests some other ideas like a powered USB hub (which does not work with the Bluebox or Blackbox- has been confirmed on the forum as well as my personal experience)


            • #7
              Originally posted by enemoy View Post
              I don't quite know how to get it into low power mode, sadly. Is there a control center by Novation?
              They outline this in the LCXL Getting Started Guide. They mention for the use with an iPad: "Hold down both the User and Factory Template buttons and insert the USB cable. Release the Template buttons and press ‘Record Arm’.* Finally press the right arrow button. The Launch Control XL is now in low power mode. This setting is remembered even if the power is disconnected. To put the Launch Control XL back into full power mode repeat the above process but press ‘Solo’ instead of ‘Record Arm’."
              Works like a charm. You can take your time between the steps.

              The difference made is that in lower power mode the LED lights on the LCXL are a little dimmed.


              • #8
                Thank you very much, it worked, but I still get the weird issue that the Novation Lauch Control starts randomly flashing. This sometimes even happens (but to a much lesser degree, when using the the power adapter by Artuira). Still. thanks for all the help and recommendations.