No announcement yet.

Reverb Low Cut parameter does not cut lows

  • Time
  • Show
Clear All
new posts

  • Reverb Low Cut parameter does not cut lows


    I am using the Bluebox with a lot more pleasure since the latest firmware that fixed the bitcrushing issue for me, which is great. I accepted the simplification of the reverb parameters as something necessary for the Bluebox to become more reliable, even though I did prefer the possibility of creating my own reverb. Right now all is pretty workeable for me, accept one detail that is being very frustrating, and I'm at the point of sacrificing two inputs, and a lot of space for an external reverb unit.

    The problem lies in the Low Cut parameter. For some reason, no matter what setting I try, the lows do not actually get cut. This becomes a big problem when adding reverb to a full drum track for example. There is no way I can have reverb on drums, while having a tight kick sound. Is there a reason that the Low Cut parameter curve functions like this? Is there a possibility that the Low Cut can function more like a High Pass filter, and actually cut all the lows?

    Not sure if I'm the only one experiencing this, but just wanted to throw this out there.

    Thanks a lot!


  • #2
    Thanks for reporting this