Announcement

Collapse
No announcement yet.

Issue with Filter Graph muting/boosting oscillators when filter is turned off

Collapse
This topic is closed.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Steve
    replied
    I have verified (and reported) the issue reported by the OP. This will be fixed.

    Leave a comment:


  • scottytown
    replied
    I am having the same problem. Unfortunately osc3 is currently muted for me and neither fiter1 or filter2 trick as suggested by diophantine has restored it. I can only hear osc3 when I raise the "wet" on either fx. If FX1 and FX2 are at zero I hear nothing from osc3.

    It's a cool device but these bugs are... worrisome. Hoping there is a fix soon!

    Leave a comment:


  • Callimero
    replied
    Oh, I always wondered about that!

    Leave a comment:


  • Steve
    replied
    Thanks for reporting this. I will investigate further.

    Leave a comment:


  • Issue with Filter Graph muting/boosting oscillators when filter is turned off

    I just got my lemondrop (1.1.2) and find the interface way more intuitive than I expected, which is great.

    Unfortunately I seem to have found a likely bug. Here's how to reproduce:
    - Load any patch (I was able to reproduce in HarmonicWall)
    - Set Filter 1 to OFF
    - Set Filter 2 to OFF
    - Set FX1 and FX2 to 0% (just so that it doesn't interfere with noticing the issue)
    - Play and hold a note (I was using the built-in key grid)
    - Go to Filter 1 and tap above the flat line in the filter graph. Oscillator 1's level is now boosted above 100%. Tap below the line and OSC1 is now muted. (Note that nothing changes in OSC1's settings when doing this.)
    - Do the same thing for Filter 2 and it will affect OSC2 in the same fashion.
    - Even if this is a "feature", there seems to be no way to reset the oscillator to the correct level after doing this.

    Note that series/parallel mode doesn't affect this behavior.
Working...
X