Announcement

Collapse
No announcement yet.

MK2 glitches/clicks when triggering multiple samples

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • MK2 glitches/clicks when triggering multiple samples

    Hi, today I've had my first chance to play around with my new MK2 and I've been running into the following problem: whenever I play/trigger two or more samples at the same time (or shortly after each other) at 'normal' pad gain settings there are clicks and/or glitches in the playback. This becomes worse when I turn the level of the individual pads up and almost completely goes away when I turn the pads way down (-20dB). This especially seems to occur when on or more of the triggered samples contain a lot of low-frequency content (kicks, toms). I've considered it could be due to some sort of clipping of the internal MK2 mixbus, but when I loaded the samples (SL Boom Bap Kit in this particular case) into Ableton Live I found that the amount of volume reduction needed to avoid bus clipping when playing for example 3 low-frequency heavy samples is way less than 20 dB per sample. The clicks/glitches also don't really sound like the audio is clipping, but more like the sound of CPU maxing out in a DAW during playback. Could this be a software problem, do I have a broken unit or is there something else I'm missing? Thanks in advance for your help!

  • #2
    Try switching off the master compressor in the tools area. That sounds like the problem. With it off, however, you will now find it easy to clip when you turn things way up.

    Comment


    • #3
      Hi Aaron, thanks for your reply. I should've added to my original post I've already tried turning the master compressor on and off which unfortunately didn't solve the problem..

      Comment


      • #4
        We have heard of some cases of bad or corrupt micro SD images. Perhaps that is the issue?

        If not, would you please post or submit an example? Ideally that would be a preset with a sequence that we an just load and hit play and see the problem.

        Internally, the firmware using floating point. Clipping won't happen on internal mixing. I'm not sure how to explain what you are seeing.

        Comment


        • #5
          Same problem here. How can I upload an example? Attachments are limited to pictures.

          The click is best described to be audible at the end of sample playback and only when more that one polyphony is used.

          Here's how you can emulate:

          Preset 1 SL Analog Drive Kit:

          Quarter note on Pad 1, Half note on Pad 2. Every time the Pad 2 is triggered there's audible click at the end of its playback while overlapped with Pad 1.
          Remove Pad 1 kick from being triggered and Pad 2 click is no longer audible.

          Preset 2 SL Analog Melodies: same as above

          Lets add more activity via triggers:

          Add a 16th trigger sequence to Pad 3 using Preset 2. The click is now starting to happen more often because Pad 3 now is triggering and overlapping with Pad 2 and Pad 1 so forth. It only takes one other Pad to trigger to cause the click.

          Comment


          • #6
            The latest 1.09 firmware just released for the Micro I'm guessing will also come for the MK2?

            Version 1.0.9 fixes the following:
            • Sometimes there is a small click at the end of a sample when playing several at once

            Comment


            • #7
              @Aaron Sorry for the late reply, I didn't have an opportunity to get to my studio sooner this week. Below I've added a link to an audio example of the problem. It's a simple sequence using the SL Boom Bap Kit. I agree internal clipping isn't the problem. I just wanted to let you know I considered it at first because of the interaction of the click problem with the individual pad volumes.

              https://www.dropbox.com/s/74kyt71skf...ample.wav?dl=0

              relicz3k The way you're describing it, it sounds like we're experiencing the exact same problem.

              The Micro firmware update seems to address this although the problem occurs pretty reliably in my MK2 and not 'sometimes' as the release notes for the new Micro firmware say. It does however seem to be a known problem? If so, I really hope there will be a firmware update soon because this problem really messes with the basic functionality of the module.

              Comment


              • #8
                Please try MK2 version 1.0.9 (which is now available) and let us know how it works out. Thanks for the effort in preparing a sample.

                Comment


                • #9
                  I had the same "clicking problem", but it completely resolved after installing Firmware 1.0.9. Thanks for the updated Firmware! Now I REALLY enjoy the module:-)

                  Comment


                  • #10
                    I finally got around to installing the new firmware and trying it out. Problem solved, thanks for the update!!

                    Comment

                    Working...
                    X