Announcement

Collapse
No announcement yet.

Trigger from Moog DFAM is randomly skipped

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Trigger from Moog DFAM is randomly skipped

    How to reproduce:

    - Ensure firmware 1.0.9 is installed.
    - Load a drum kit.
    - Patch DFAM “Trigger” OUT to a Bitbox sample trigger (I use a hi-hat).
    - Press “RUN“ on DFAM to start sequencer.
    - Observe that the sample is sometimes (randomly) skipped.

    NOTE; I cannot reproduce this issue with Moog Subharmonicon clock out. The main difference is that DFAM is sending trigger pulse as +5v for 1 millisecond, while Subharmonicon is sending clock pulse at +5v for 5 milliseconds. This seems an issue with trigger inputs sampling. Triggers should be sampled using a minimum frequency of 2000 Hz.

  • #2
    Thanks for reporting this issue.

    1ms is a very narrow pulse. This issue has come up before. One of the Mutable Instruments modules had the same situation. I think it was Grids. They added an option to make the pulse wider, which made lots of other modules, like ours, work reliably with it.

    We will keep this in mind for future updates. Increasing the sampling rate does consume more CPU.

    Comment


    • #3
      Originally posted by Aaron View Post
      We will keep this in mind for future updates. Increasing the sampling rate does consume more CPU.
      Thanks. A new “High-res polling” option in a future firmware would be great.
      What’s the minimum pulse width that is supported at the moment for triggers ?

      Comment


      • #4
        We recommend using 5ms pulses or longer. We will keep your request in mind.

        Comment

        Working...
        X