Announcement

Collapse
No announcement yet.

Noisy?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Noisy?

    Have my BBM (fw 1.2.3) in my Intellijel performance case and it is adding a lot of noise when it is plugged in. I've tried adjusting the brightness. Any suggestions other than moving it to another case (really not an option)?

    Thanks!

  • #2
    Don't know if the BBM does the same, but I did have noise on a filter+amp module once, until I changed the power supply. Try changing the power supply, just to test if that solves the problem? The power supply you use now may be overloaded - so you could also try disconnectiing other modules connected to the same power supply, and see if it changes anything.

    Comment


    • #3
      HenrikJX3D, thanks for the suggestion! I tried another PSU today but it was the same make/model (a Meanwell 90W unit). Given the specs of the Intellijel that should be enough power. It is also the PSU that came with the case FWIW.

      I did try disconnecting other modules though only one at a time. Only the BBM had any impact on the noise.

      Comment


      • #4
        Okay, but at least that part is checked out now, and not the problem. Hope you get it solved somehow.

        Comment


        • #5
          I’ve had this noise in my modular system for a little while now that I have been trying to track down. Today I found it by chance, I just so happen to fiddle with the rack screw on my Bitbox Micro, and the noise suddenly went away….whoa! I couldn’t believe it, I finally tracked it down. I too have an Intellijel performance case. If I twist any of the rack screws while my case is on the the noise comes and goes. Coincidentally I just noticed my screen is starting to flicker as well. I guess it’s time to email tech-support

          Comment

          Working...
          X