Announcement

Collapse
No announcement yet.

New Bitbox Micro - screen died upon lowering brightness

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Same problem here , already email you Aaron,,..Click image for larger version

Name:	JPEG_20200804_155412_7311370660533448040.jpg
Views:	256
Size:	3.17 MB
ID:	16632

    Comment


    • #17
      I posted a few weeks ago that this happened to mine. Support was good, repair turnaround was quick, and the repaired unit works great. I have my screen at 33% brightness. I'm still exploring what the Bitbox Micro can do but so far it's exactly what I wanted.

      Comment


      • #18
        Just got a bitbox micro... powered up the screen came on... very bright... went to settings to adjust brightness... screen went blank... didn't even get a chance to hear it!...
        I have tried the troubleshooting, deleting settings on sd-card, start while holding HOME... nothing.
        I have sent a contact email.

        Comment


        • #19
          Same problem on my side. Bitbox micro, screen went black after less than 5 hours. I'm having a hard time getting a replacement with european distributor Signal Sounds ....

          Comment


          • Steve
            Steve commented
            Editing a comment
            Contact us directly at [email protected] if you do not hear from your dealer.

        • #20
          I just contacted Bitbox directly. Same issue. Thrilled to get it from Schneidersladen today (I'm in L.A.), dead within 5 minutes because I tried to lower the brightness. I know Bitbox will take care of me, and I suspect this will be the sampler for me, but Bitbox, I strongly suggest you recall these modules globally and fix the problem.

          Comment


          • #21
            I'm so sad... I just got hit with the dead screen bug (smoke and all!).
            I had my Micro for about a week before this and I was LOVING it! I hope this can be turned around quickly... seems like 1010 is pretty good about supporting their users (based on this tread alone).
            Even thou this is a bummer, I still want to congratulate 1010 on an awesome product, I can't wait 'till it's fixed!

            Comment


          • #22

            I must be either doomed or there is something really wrong in the design. I finally got a replacement unit after 4 weeks waiting, the new one's screen died after less than 10 minutes. And this happened not touching any brightness settings, just installed it and by the time i sent an email to the dealer to thank him , this new unit's screen died . This is happening in a brand new 7U Intellijel case with already a few digital modules, all very happy. I'm feeling really annoyed right now
            Last edited by jayceefr; 10-03-2020, 11:40 AM.

            Comment


            • Aaron
              Aaron commented
              Editing a comment
              That is terrible news. Please email us at [email protected] so that we can make arrangements for you.

          • #23
            well at least my dealer and people from 1010 have acknowledged that there is a hardware problem. now i can just countdown until this post is deleted.
            Hopefully google bot will grab it before

            Comment


            • Steve
              Steve commented
              Editing a comment
              There is no need to delete. The issue with the micro has, for sure, been a frustrating one for us (and you). We have acknowledged this issue and have fixed every one of them at our expense. We will continue to provide this level of support to all of you. We do believe that we have identified the components causing the issue and we have made the necessary adjustments with our factory.

          • #24
            I also tried everything mentioned here. Additionally, after trying these steps my unit does not recreate a new settings.tml file. Can anyone here who has experienced this problem without being able to fix it on their own comment on what steps have been taken by Bitbox?

            Thanks!

            Comment


            • Aaron
              Aaron commented
              Editing a comment
              I'm not sure what the other folks will be able to offer. Sadly, the resolution is usually sending the unit back for repair/replacement. Please use the Contact Us form to get in touch so we can make arrangements specifically for you. We do our best to turn around the unit in a few days.

          • #25
            Originally posted by jayceefr View Post
            well at least my dealer and people from 1010 have acknowledged that there is a hardware problem. now i can just countdown until this post is deleted.
            Hopefully google bot will grab it before

            "There is no need to delete. The issue with the micro has, for sure, been a frustrating one for us (and you). We have acknowledged this issue and have fixed every one of them at our expense. We will continue to provide this level of support to all of you. We do believe that we have identified the components causing the issue and we have made the necessary adjustments with our factory."

            Wow i think this is a bit rude for a member of staff to highlight " at our expense " , with an issue like this with a new product i wouldn't expect anything less than the Micro being fixed "at your expense " and to be honest watching this from the sidelines i can't understand why you haven't recalled all the micros from the batch concerned and resolved the issue otherwise your going to have some pretty pee'd users if the screen dies a week after the warranty runs out and you charge for the repair . Just saying

            I for one would be scared to buy one for sure

            Comment


            • #26
              I really want to buy one of these, but now I'm worried. How can we know if a module is problematic or not? Is there any info about the batch number or how to make sure / test if a module can be faulty???

              Comment


              • #27
                Originally posted by Paranormal Patroler View Post
                I really want to buy one of these, but now I'm worried. How can we know if a module is problematic or not? Is there any info about the batch number or how to make sure / test if a module can be faulty???
                Thank you for your question. Here is where things currently stand:
                • We have spent a lot of time on this issue and believe we now fully understand it. Everyone who has contacted us has gotten an updated unit and to the best of my knowledge everyone is back in business.
                • We added a new test at the factory to make sure that every unit goes through several rounds of changing the brightness to make sure the unit is OK.
                • The second batch of bitbox micro production, released in September, has a hardware update built in.
                • The current firmware, version 1.0.12, also has code to prevent screen burn out.
                • We plan to fix this issue at our expense for the foreseeable future. In other words, the one year warranty won't apply to screen burnout on bitbox micro. We will take care of it and turn around your repair in a few days.
                Let me thank everyone for your patience. I hope this reassures you. Let me know if not.

                Comment


                • #28
                  Originally posted by Aaron View Post
                  Let me thank everyone for your patience. I hope this reassures you. Let me know if not.
                  It does. I reached out to my favourite retailer Synthesizer.gr and they said their batch is fairly new, so I bought one from there. Located in EU so fixing/replacing is not exactly straightforward or easy for me as it entails customs and long waiting times. So if I can get something that works, that would be best.

                  But I feel reassured to know that you're taking care of people who run into trouble with the Micro. Contrary to standard practice, the first thing I'll do is check the screen brightness!

                  Comment


                  • Aaron
                    Aaron commented
                    Editing a comment
                    Please upgrade to firmware 1.0.12 as the very first step. Thank you for your support.

                • #29
                  So I’ve recently bought the Micro and I love it but many other brightness settings other than 100% induces flickering. Do I have one from the faulty batch?
                  Thanks for your help!

                  Comment


                  • Aaron
                    Aaron commented
                    Editing a comment
                    Have you tried the Bright Fine control on the Tools menu? (This is not available in the factory firmware. Please upgrade to 1.0.12)

                    If that doesn't solve it, please use the contact us form on our website to make specific arrangements for you.
                Working...
                X