Announcement

Collapse
No announcement yet.

Clip sync to playback problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Clip sync to playback problem

    Hello all,
    New Micro user here. So far I love the module. It has brought a lot of new possibilities it to my rack.
    I'm using it with Nerdseq via MIDI and it's really powerful that way as I have all eight inputs free for CV.
    But I started to experience this problem. I have clip that is quant sized to 1 bar and synced to 1/16 to fit the 4 bars of 16 notes on Nerdseq. Sometimes clip does not start when it is supposed to and starts on second bar. I can see the pad was triggered at the start of 1st bar but it is blinking white and then starts on 2nd bar. When I change settings of quant size to i.e. 1/16 it sometimes starts 1/16 later and plays off beat. I thing its not a midi issue since I tried to trigger it from CV output of Nerdseq. It happens like 1-2 times from 10.

  • #2
    To simply put it. Clip playback does not always start on first beat. It sometimes starts after set quant size unit. Be it 1/16 or 1bar.
    To me it looks like pad is sometimes triggered after Micro recieved clock reset. So it has to wait for another quant size unit.

    Comment


    • #3
      Ok, I have an update. I noticed that even when clip starts one "quant size unit" later, micro catches up very soon to play in sync. So if this issue cannot be somehow solved, It would be nice to be be able to set quant size to even smaller setting. 1/32 would make the delay much less noticable.

      Comment


      • #4
        what is your content? Can you share it?

        Comment


        • #5
          I’m running into the same problem – are there any updates concerning this?

          Comment


          • #6
            The described behavior (above) sounds correct. If you set the QuantSize to 1 bar, you will need to trigger that Clip up to 1 bar before you want it to begin. If you set QuantSize to 1 bar and send the trigger when you want the Clip to begin, you should expect to hear the Clip begin at the start of the next bar.

            Comment


            • #7
              The problem with this behavior is that it’s impossible to play time-stretched clips that start on the 1 of a sequence. Maybe an option to ignore sync when the free-running sync counter resets to zero? Or something similar?

              Comment


              • #8
                have you tried a smaller QuantSize? Or none?

                Comment


                • #9
                  I use "none" for quantsize and it triggers immediately using midi from XOR NerdSEQ.

                  Hope that helps.

                  Comment


                  • #10
                    Thanks, I really appreciate the help! I just wanted to ask: Wouldn't setting Quant size to NONE result in timestretching getting disabled?

                    "Sync is only enabled when quantizing is enabled (the Quant Size parameter is not None.)"

                    Steve: I tried various, including the smallest Quantsize (1/32? 1/16?) – It just results in the clip being late by the appropriate time.

                    Comment


                    • Steve
                      Steve commented
                      Editing a comment
                      send the trigger earlier.

                  • #11
                    It’s not really a solution, as I’m pressing play on a sequencer. I’m surprised I’m the only one struggling with this, as it’s fairly basic – press play, and you’ll hear sound. But not with the Bitbox, if you’ve timestretched the clip.

                    Is there any way 1010 Music could be persuaded to consider this matter?

                    EDIT: it seems like sometimes the sample starts playing, other times not, if that helps troubleshoot.
                    Last edited by Josker; Yesterday, 11:55 AM.

                    Comment


                    • #12
                      We consider everything.

                      Fundamentally, the QuantSize determines how long the unit will wait to start the Clip. So if you set it to 1/16th you should expect it to begin 1/16th later than the trigger. And this will cause a weirdly out-of-beat loop against the rest of your music. For example, set QuantSize to 1 bar and send the trigger at any time up to 1 bar before you want the Clip to begin. If you want the Clip to being in bar 9 - send the trigger in bar 8. If you are beginning a piece this way, leave (at least) 1 bar of space at the start of your sequence in order to queue all of your tracks, Clips, loops, etc.

                      Comment

                      Working...
                      X