Announcement

Collapse
No announcement yet.

Loose screen

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Loose screen

    Hi , i have just taken delivery today of a Toolbox but when it arrived form the retailer there was no screen protector and the cable was on the back of the module already and once i plugged the module in to use it the screen actually moves slightly and you can see the finger prints spreading out the graphics .
    Has anyone else had issues with the screen . Lovely sequencer btw
    Cheers
    John

  • #2
    Originally posted by Filterfreak View Post
    Hi , i have just taken delivery today of a Toolbox but when it arrived form the retailer there was no screen protector and the cable was on the back of the module already and once i plugged the module in to use it the screen actually moves slightly and you can see the finger prints spreading out the graphics .
    Has anyone else had issues with the screen . Lovely sequencer btw
    Cheers
    John
    Hi John,

    It's actually hard to keep the screen protector on through the manufacturing process, but leave it accessible to remove. So sometimes it doesn't make it. We also attached the cable in the past and sometimes still do. So those two things don't worry me. However, the screen moving and finger prints spreading sound suspicious. Could you please use the Contact Us link above to send us an email to get in touch directly? We can then ask you to send us some photos or videos to show the issue. If we can't resolve it via email, we can discuss getting you a replacement.

    Sorry you are having trouble,
    Christine

    Comment


    • #3
      Originally posted by Christine View Post

      Hi John,

      It's actually hard to keep the screen protector on through the manufacturing process, but leave it accessible to remove. So sometimes it doesn't make it. We also attached the cable in the past and sometimes still do. So those two things don't worry me. However, the screen moving and finger prints spreading sound suspicious. Could you please use the Contact Us link above to send us an email to get in touch directly? We can then ask you to send us some photos or videos to show the issue. If we can't resolve it via email, we can discuss getting you a replacement.

      Sorry you are having trouble,
      Christine
      Hi Christine
      Thank you for your reply , sorry i never saw this earlier , i have actually returned the module back to the retailer ( Rubadub ) who were fantastic with helping and sent out another module .
      The second one i received is perfect all thou they seem like a completely different screen to the ones used in the Bitbox ? .
      Anyway I love Both the modules and plan on buying the other Two ( synth / Fx ) so no harm done . I think it was just a rogue module .

      Thanks
      John

      Comment


      • Christine
        Christine commented
        Editing a comment
        Glad you got it sorted out. Although Toolbox and bitbox use the same screen, so I'm not sure what you are seeing to think they are different. Let me know if you continue to have issues.
    Working...
    X